Updated deployment descriptors of WebLogic Server

U

weblogic.xml.process.XMLProcessingException: Error: For EJB modules, deployment plan overrides are not supported with DTD based deployment descriptors. The EJB module prbeans.jar is attempting to apply a deployment plan to DTD based descriptors. Please update your EJB deployment descriptors to be schema based before attempting to apply the deployment plan override to this module. The weblogic.DDConverter utility can be used to automatically update your descriptors. Run the weblogic.DDConverter utility on your application to update the deployment descriptors. After the descriptors are updated, the deployment plan overrides can be applied to the EJB module properly. 

Message icon – Error Error: For EJB modules, deployment plan overrides are not supported with DTD based deployment descriptors. The EJB module prbeans.jar is attempting to apply a deployment plan to DTD based descriptors. Please update your EJB deployment descriptors to be schema based before attempting to apply the deployment plan override to this module. The weblogic.DDConverter utility can be used to automatically update your descriptors. Run the weblogic.DDConverter utility on your application to update the deployment descriptors. After the descriptors are updated, the deployment plan overrides can be applied to the EJB module properly. 

source /x/bea-wl1213/wlserver/server/bin/setWLSEnv.sh 

java weblogic.DDConverter -d prpc_j2ee14.ear 

Leave a Reply