WebLogic Admin Server hangs during startup

Admin Server hangs during startup, the stdout doesn’t go beyond initialising security realm.

We took thread dump when Admin Server was stuck during startup and found the below thread connecting to the nodemanager.

[STANDBY] ExecuteThread: ‘1’ for queue: ‘weblogic.kernel.Default (self-tuning)'” #24 daemon prio=5 os_prio=0 tid=0x00007f7720002000 nid=0x2be9 runnable [0x00007f7760db3000]
java.lang.Thread.State: RUNNABLE
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
– locked <0x00000000d57c80e8> (a java.net.SocksSocketImpl)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
at weblogic.nodemanager.client.DefaultSSLClient.createSocket(DefaultSSLClient.java:32)
at weblogic.nodemanager.client.NMServerClient.connect(NMServerClient.java:452)
at weblogic.nodemanager.client.NMServerClient.checkConnected(NMServerClient.java:424)
at weblogic.nodemanager.client.NMServerClient.checkConnected(NMServerClient.java:430)
at weblogic.nodemanager.client.NMServerClient.initState(NMServerClient.java:411)
– locked <0x00000000d57c41b8> (a weblogic.nodemanager.client.DefaultSSLClient)
at weblogic.nodemanager.client.DefaultSSLClient.initState(DefaultSSLClient.java:14)
at weblogic.nodemanager.mbean.NodeManagerRuntime.initState(NodeManagerRuntime.java:425)
at weblogic.server.ServerLifeCycleRuntime.(ServerLifeCycleRuntime.java:134)
at weblogic.server.ServerLifeCycleService.createServerLifeCycleRuntime(ServerLifeCycleService.java:264)
at weblogic.server.ServerLifeCycleService.start(ServerLifeCycleService.java:150)

One investigating further we found one of the host was not responsive and we suspected that the Admin Server is not able to communicate with the node manager on that host. We looked for any such known issue with Weblogic Server and found the one below.

WLS 12.1.3.0.0 – Weblogic Admin Server Hangs While Starting Up (Doc ID 2241843.1)

For us the issue was resolved by fixing the host issue but we also plan to install the patch for this issue.

Leave a Reply